Kalix service proxy gives error

I am trying my first (scala) project/service. I am trying out the customerregistry example.
I see the service listed with a READY status when I do kalix services list.
However, when I do: kalix service proxy firstservice --grpcui
I get back: Error: error performing discovery on service: error making proxied request: the server is currently unable to handle the request
What am I doing incorrectly?

Hi venkykrishnan,

Great to hear about your interest in Kalix.
I’ve just tried it out and it seems to have worked as expected.

Is it possible that you have some kind of firewall blocking such connections? Some enterprise setups might get in the way.

Also, can you confirm you’re on the latest CLI version:

~ kalix version

Yes, kalix version is 2.0.16.
I also suspect its got to do with my firewall. Is there any guidance on opening connections such as specific port I need to open?

I was doing some experiments but I cannot reproduce your error message. The established connection is HTTPS, so should only need port 443 I believe.

that worked. I had to open the port.