Issues with Customer-Registry-Scala Quickstart

Hi, Thanks for allowing us to trial Kalix.

I’m trying the customer-registry-scala quickstart on M1 Mac with latest Scala, Docker,… and GitLab for container registry.

I get some warnings and errors during the Docker/publish but it seems to complete successfully (or at least that’s what it says).

When I kalix service deploy customer-registry… it seems to deploy the image to Kalix and tries to run but doesn’t succeed.

It sits at “Pending” for a while then goes to “Unavailable.”

I have checked the image architecture and it seems to be “amd64” (as mentioned in another similar forum post).

Some output from the Docker/publish command appended below.

Any help would be most appreciated.


[warn] [1] There are no exposed ports for your docker image
[warn]  Configure the `dockerExposedPorts` or `dockerExposedUdpPorts` setting. E.g.
[warn]  // standard tcp ports
[warn]  dockerExposedPorts ++= Seq(9000, 9001)
[warn]  // for udp ports
[warn]  dockerExposedUdpPorts += 4444
[success] All package validations passed
[error] #1 [internal] load build definition from Dockerfile
[error] #1 transferring dockerfile: 1.05kB done
[error] #1 DONE 0.0s
[error] #2 [internal] load .dockerignore
[error] #2 transferring context: 2B done
[error] #2 DONE 0.0s
[error] #3 [internal] load metadata for
[error] #3 ...
[error] #4 [stage0 1/7] FROM
[error] #4 DONE 0.0s
[error] #5 [internal] load build context
[error] #5 transferring context: 1.55MB 0.0s done
[error] #5 DONE 0.0s
[error] #6 [stage0 2/7] WORKDIR /opt/docker
[error] #6 CACHED
[error] #3 [internal] load metadata for
[error] #3 ...
[error] #7 [stage0 3/7] COPY 1/opt /1/opt
[error] #7 DONE 0.1s
[error] #8 [stage0 4/7] COPY 2/opt /2/opt
[error] #8 DONE 0.0s
[error] #9 [stage0 5/7] RUN ["chmod", "-R", "u=rX,g=rX", "/1/opt/docker"]
[error] #9 DONE 0.3s
[error] #10 [stage0 6/7] RUN ["chmod", "-R", "u=rX,g=rX", "/2/opt/docker"]
[error] #10 DONE 0.2s
[error] #11 [stage0 7/7] RUN ["chmod", "u+x,g+x", "/1/opt/docker/bin/customer-registry"]
[error] #11 DONE 0.1s
[error] #12 [mainstage 2/5] RUN id -u demiourgos728 1>/dev/null 2>&1 || (( getent group 0 1>/dev/null 2>&1 || ( type groupadd 1>/dev/null 2>&1 && groupadd -g 0 root || addgroup -g 0 -S root )) && ( type useradd 1>/dev/null 2>&1 && useradd --system --create-home --uid 1001 --gid 0 demiourgos728 || adduser -S -u 1001 -G root demiourgos728 ))
[error] #12 CACHED
[error] #13 [mainstage 3/5] WORKDIR /opt/docker
[error] #13 CACHED
[error] #14 [mainstage 4/5] COPY --from=stage0 --chown=demiourgos728:root /1/opt/docker /opt/docker
[error] #14 DONE 0.1s
[error] #15 [mainstage 5/5] COPY --from=stage0 --chown=demiourgos728:root /2/opt/docker /opt/docker
[error] #15 DONE 0.0s
[error] #3 [internal] load metadata for
[error] #3 ...
[error] #16 exporting to image
[error] #16 exporting layers 0.1s done
[error] #16 writing image sha256:b5b6c960f88464a274be875adcbeea2f65706f4d82ebaeef9d0eb7612d31e07f done
[error] #16 naming to<usernam/customer-registry:HEAD-20221125-1305 done
[error] #16 naming to<username>/customer-registry:latest done
[error] #16 DONE 0.1s

The image works properly when running locally with kalix-proxy.

Hey Ashley,

Thanks for your interest in Kalix. It seems that we are having issues pulling down the image from gitlab.
I tried to look up the image directly but also found a 404.

Is the image publicly available? If not, and requires authentication, make sure to add the required credentials, as mentioned in Configuring container registries.

1 Like


Thank you very much for the prompt reply. That did the trick, i.e. adding a private container registry.

I should have thought of that :frowning: but couldn’t see any indication on the service console.


Glad it’s solved!

I should have thought of that :frowning: but couldn’t see any indication on the service console.

I would assume there should be some mention of the issue on the logs, either by accessing the kalix web console or using kalix logs. Let’s us know if that was not the case or if something was not obvious for you and we can try to improve it. :slight_smile:

1 Like