Kalix SDK version error/warning

Hi,

Following the release of the Kalix Java/Scala SDK 1.0.4, we’ve just noticed an error log entry at startup of our services, most of which are using v1.0.2 or earlier, that looks as follows:

Error reported from Kalix system: KLX-00011 A newer version of the kalix-java-sdk [1.0.4] is available. Your current version is [1.0.3].

(which I incidentally saw after updating one of our services to v1.0.3 following seeing a similar message yesterday before the release of 1.0.4)

Considering that each release so far adds improvements and bug fixes, we obviously try to keep pace as much as possible. But can we treat this as a mere warning/notice, or does this indicate that there might be some breaking changes? Thanks in advance

Yes, it is more intended to notify than to be a general error. It is not signaling a breaking change, so you can ignore and update when it suits you.

We currently do not have a severity/level for those log events sent to the SDKs from the proxy, we’ll see if we can improve on that in the future and turn this into a warning or perhaps even info.

Alright, as we suspected then, thanks for the quick answer though :slight_smile:

The combination of the instructions following the message and the log level felt rather imperative:

To fix this issue, update the version of kalix-java-sdk in your Kalix service. Then build and deploy a new version of it.

As a small suggestion; merely changing the wording might clarify things until you can get around to changing the severity

2 Likes